<?xml version='1.0' encoding='UTF-8'?>
<?xml-stylesheet href="/static/style.xsl" type="text/xsl"?>
<feed xmlns="http://www.w3.org/2005/Atom" xml:lang="en">
  <id>https://cve.radiocsirt.org/rss/recent/all/10</id>
  <title>Most recent entries from all</title>
  <updated>2026-10-27T03:57:12.443535+00:00</updated>
  <author>
    <name>Vulnerability-Lookup</name>
    <email>csirt@opendfir.org</email>
  </author>
  <link href="https://cve.radiocsirt.org" rel="alternate"/>
  <generator uri="https://lkiesow.github.io/python-feedgen" version="1.0.0">python-feedgen</generator>
  <subtitle>Contains only the most 10 recent entries.</subtitle>
  <entry>
    <id>https://cve.radiocsirt.org/vuln/euvd-2026-59814</id>
    <title>EUVD-2026-59814</title>
    <updated>2026-10-27T03:57:12.446512+00:00</updated>
    <content>EUVD-2026-59814</content>
    <link href="https://cve.radiocsirt.org/vuln/euvd-2026-59814"/>
  </entry>
  <entry>
    <id>https://cve.radiocsirt.org/vuln/fkie_cve-2019-20174</id>
    <title>fkie_cve-2019-20174</title>
    <updated>2026-10-27T03:57:12.446549+00:00</updated>
    <content type="xhtml">
      <div xmlns="http://www.w3.org/1999/xhtml">
        <p>Auth0 Lock before 11.21.0 allows XSS when additionalSignUpFields is used with an untrusted placeholder.</p>
      </div>
    </content>
    <link href="https://cve.radiocsirt.org/vuln/fkie_cve-2019-20174"/>
  </entry>
  <entry>
    <id>https://cve.radiocsirt.org/vuln/ghsa-w2pf-g6r8-pg22</id>
    <title>GHSA-w2pf-g6r8-pg22 — auth0-lock vulnerable to XSS via unsanitized placeholder property</title>
    <updated>2026-10-27T03:57:12.446611+00:00</updated>
    <content type="xhtml">
      <div xmlns="http://www.w3.org/1999/xhtml"><p><strong>Affected:</strong> npm: auth0-lock</p>
<p>## Overview</p>
<p>Auth0 Lock version 11.20.4 and earlier did not properly sanitize the generated HTML code. Customers using the `additionalSignUpFields` customization option to add a checkbox to the sign-up dialog that are passing a `placeholder` property obtained from an untrusted source (e.g. a query parameter) could allow cross-site scripting (XSS) on their signup pages.</p>
<p>## Am I affected?</p>
<p>You are affected by this vulnerability if all of the following conditions apply:</p>
<p>- You are using Auth0 Lock version 11.20.4 or earlier.
- You pass `additionalSignUpFields` as options when initializing Lock which includes a field of type `checkbox` whose `placeholder` value is obtained from an untrusted source.</p>
<p>An example of a vulnerable snippet is the following where the `placeholder` value is partially user-controlled by the `name` query parameter:</p>
<p>```javascript
&lt;script&gt;
    var params = new URLSearchParams(window.location.search);
    var options = {
        auth: {
            redirectUrl: 'http://localhost:12345/callback',
            responseType: 'code',
            params: {
                scope: 'openid email',
            },
        },
        additionalSignUpFields: [{
            name: 'agree',
            type: 'checkbox',
            placeholder: "I agree to Terms and Conditions for " + params.get('name'),
        }],
    };
    var lock = new Auth0Lock('&lt;CLIENT_ID&gt;', '&lt;TENANT_NAME&gt;.auth0.com', options);
    lock.show({
        allowShowPassword: true,
        initialScreen…</p></div>
    </content>
    <link href="https://cve.radiocsirt.org/vuln/ghsa-w2pf-g6r8-pg22"/>
  </entry>
  <entry>
    <id>https://cve.radiocsirt.org/vuln/gsd-2019-20174</id>
    <title>gsd-2019-20174</title>
    <updated>2026-10-27T03:57:12.446694+00:00</updated>
    <content>gsd-2019-20174</content>
    <link href="https://cve.radiocsirt.org/vuln/gsd-2019-20174"/>
  </entry>
</feed>
